Follow

Android™ Device Compatibility

Navdy will work on Android phones running KitKat (version 4.4) or above. 

Navdy is not compatible with:

  • Android phones running Jelly Bean (version 4.3.1) or below
  • Android Tablets
Was this article helpful?
0 out of 0 found this helpful
Can't find what you're looking for?

Submit your question here

Or ask our Community!